CompilingSource

From ago control wiki
(Difference between revisions)
Jump to: navigation, search
m (Dependencies)
m (Dependencies)
Line 4: Line 4:
 
  apt-get install quilt devscripts libudev-dev libqpidclient2-dev uuid-dev libqpidcommon2-dev libqpidmessaging2-dev \  
 
  apt-get install quilt devscripts libudev-dev libqpidclient2-dev uuid-dev libqpidcommon2-dev libqpidmessaging2-dev \  
 
  git libqpidtypes1-dev g++-4.6 libtinyxml2-dev libjsoncpp-dev libyaml-cpp-dev libsqlite3-dev \
 
  git libqpidtypes1-dev g++-4.6 libtinyxml2-dev libjsoncpp-dev libyaml-cpp-dev libsqlite3-dev \
  libopenzwave1.0-dev libi2c-dev libeibclient-dev intltool libboost-dev intltool libboost-date-time-dev realpath libhdate-dev
+
  libopenzwave1.0-dev libi2c-dev libeibclient-dev intltool libboost-dev intltool libboost-date-time-dev realpath libhdate-dev libcurl4-openssl-dev
  
 
=== Get the source ===
 
=== Get the source ===

Revision as of 00:58, 3 January 2014

Contents

Debian Wheezy

Dependencies

You can use the dev packages for knx and z-wave from our mirror or compile them from source (please be aware that the bcusdk source needs tweaking for some platforms like armhf)

apt-get install quilt devscripts libudev-dev libqpidclient2-dev uuid-dev libqpidcommon2-dev libqpidmessaging2-dev \ 
git libqpidtypes1-dev g++-4.6 libtinyxml2-dev libjsoncpp-dev libyaml-cpp-dev libsqlite3-dev \
libopenzwave1.0-dev libi2c-dev libeibclient-dev intltool libboost-dev intltool libboost-date-time-dev realpath libhdate-dev libcurl4-openssl-dev

Get the source

git clone http://agocontrol.com/agocontrol.git

Build the package

Change into the git dir and run:

dpkg-buildpackage -b -uc -us
Personal tools